diff Makefile.am @ 31588:7c020b18e299 stable

build: Change Makefile rules to get 'make distcheck' to pass. * Makefile.am: Remove ".PHONY" specification from NEWS target. * test/Makefile.am: Add DIRSTAMP_FILES to DISTCLEANFILES variable.
author Rik <rik@octave.org>
date Tue, 29 Nov 2022 11:08:05 -0800
parents d6817b3308b1
children bac84a43cff6
line wrap: on
line diff
--- a/Makefile.am	Tue Nov 29 07:14:45 2022 -0800
+++ b/Makefile.am	Tue Nov 29 11:08:05 2022 -0800
@@ -391,8 +391,8 @@
 	$(AM_V_GEN)$(gdbinit-install-rule)
 
 NEWS: etc/NEWS.$(OCTAVE_MAJOR_VERSION).md
-	$(AM_V_GEN)cp $< $@
-.PHONY: NEWS
+	$(AM_V_GEN)rm -f $@ && \
+	cp $< $@
 
 define changelog-from-hg-log
   rm -f $@-t && \