diff test/Makefile.am @ 32862:833f3d9bdf1a stable

Don't treat parent class constructor as inherited class method (bug #65037) * fcn-info.cc (fcn_info::fcn_info_rep::find_method): Ignore any methods that are actually parent class constructors. * ov-classdef.cc (octave_classdef_meta::is_classdef_constructor): Also consider methods and parent classes. * test/bug-65037/bug-65037.tst, test/bug-65037/bug65037_base.m, test/bug-65037/bug65037_derived.m, test/bug-65037/module.mk: New test files. * test/Makefile.am: Update.
author John W. Eaton <jwe@octave.org>
date Fri, 12 Jan 2024 16:28:48 -0500
parents e96e2f9f9f37
children 0c9675a32703 a575aa730d84
line wrap: on
line diff
--- a/test/Makefile.am	Fri Jan 26 14:19:39 2024 +0100
+++ b/test/Makefile.am	Fri Jan 12 16:28:48 2024 -0500
@@ -110,6 +110,7 @@
 include bug-61105/module.mk
 include bug-61191/module.mk
 include bug-63841/module.mk
+include bug-65037/module.mk
 include class-concat/module.mk
 include classdef/module.mk
 include classdef-debug/module.mk