diff configure.ac @ 31982:86eb373a6c64 stable

build: Check whether using STL from LLVM or Apple (bug #63930). * m4/acinclude.m4 (OCTAVE_LLVM_LIBCXX): Some Octave features that rely on the STL don't work correctly with libc++ from LLVM or Apple. Add a check that allows referring to the used STL on build and run time. * configure.ac: Run new DEFUN.
author Markus Mützel <markus.muetzel@gmx.de>
date Thu, 06 Apr 2023 09:29:24 +0200
parents 2460c1e69799
children ff1fed5bf218 fdadf31961bb
line wrap: on
line diff
--- a/configure.ac	Fri Apr 07 12:18:28 2023 -0700
+++ b/configure.ac	Thu Apr 06 09:29:24 2023 +0200
@@ -541,6 +541,10 @@
 AC_DEFINE_UNQUOTED(OCTAVE_IDX_TYPE, [$OCTAVE_IDX_TYPE],
   [Define to the type of octave_idx_type (64 or 32 bit signed integer).])
 
+### Check for LLVM or Apple libc++ library.
+
+OCTAVE_LLVM_LIBCXX
+
 ### Check for pthread library.
 
 AX_PTHREAD