diff libinterp/dldfcn/gzip.cc @ 29163:8f67ad8b3103

maint: Updating naming conventions for exceptions and use const where possible. * GLCanvas.cc, interpreter-qobject.cc, file-editor-tab.cc, octave-qscintilla.cc, octave-qobject.cc, Cell.cc, __eigs__.cc, __magick_read__.cc, __qp__.cc, daspk.cc, dasrt.cc, dassl.cc, data.cc, file-io.cc, graphics.cc, graphics.in.h, input.cc, interpreter.cc, ls-mat-ascii.cc, lsode.cc, oct-handle.h, oct-map.cc, quad.cc, rand.cc, sparse.cc, sub2ind.cc, toplev.cc, utils.cc, __init_gnuplot__.cc, __ode15__.cc, cdef-object.cc, ov-base-diag.cc, ov-base-mat.cc, ov-base-sparse.cc, ov-base.cc, ov-fcn-handle.cc, ov-java.cc, ov-perm.cc, ov-range.cc, ov-re-diag.cc, ov-str-mat.cc, ov.cc, pt-assign.cc, pt-eval.cc, pt-idx.cc, pt-jit.cc, pt.cc, Array-util.cc, randmtzig.cc: Update naming conventions for exceptions to use initial letter of exception type. For example, "execution_exception" is named "ee", "index_exception" is "ie". Catch "const" exceptions where possible. * gzip.cc: Add block to catch and throw interrupt_exceptions before having a catch block "(...)" for everything else.
author Rik <rik@octave.org>
date Tue, 08 Dec 2020 13:25:03 -0800
parents c40a367a84c0
children 7854d5752dd2
line wrap: on
line diff
--- a/libinterp/dldfcn/gzip.cc	Tue Dec 08 21:34:55 2020 +0100
+++ b/libinterp/dldfcn/gzip.cc	Tue Dec 08 13:25:03 2020 -0800
@@ -508,13 +508,17 @@
             {
               X::zip (path, dest_path);
             }
+          catch (const interrupt_exception&)
+            {
+              throw;  // interrupts are special, just re-throw.
+            }
           catch (...)
             {
               // Error "handling" is not including filename on the output list.
-              // Also remove created file which maybe was not even created
+              // Also, remove created file which may not have been created
               // in the first place.  Note that it is possible for the file
-              // to exist in the first place and for X::zip to not have
-              // clobber it yet but we remove it anyway by design.
+              // to exist before the call to X::zip and that X::zip has not
+              // clobber it yet, but we remove it anyway.
               sys::unlink (dest_path);
               return;
             }