diff Makefile.am @ 10360:9126d71f53aa

add gdbinit file to sources
author John W. Eaton <jwe@octave.org>
date Thu, 25 Feb 2010 12:02:39 -0500
parents 02453ee20140
children cbf6eebb2a0b
line wrap: on
line diff
--- a/Makefile.am	Thu Feb 25 14:45:32 2010 +0100
+++ b/Makefile.am	Thu Feb 25 12:02:39 2010 -0500
@@ -52,6 +52,7 @@
   ROADMAP \
   SENDING-PATCHES \
   autogen.sh \
+  gdbinit \
   missing \
   mk-opts.pl \
   mkinstalldirs \
@@ -102,7 +103,7 @@
 
 nodist_octinclude_HEADERS = config.h
 
-all-local: $(bin_SCRIPTS) $(INFO_FILES)
+all-local: $(bin_SCRIPTS) $(INFO_FILES) .gdbinit
 	@echo ""
 	@echo "Octave successfully built.  Now choose from the following:"
 	@echo ""
@@ -154,6 +155,13 @@
 	@$(do_subst_script_vals)
 	chmod a+rx "$@"
 
+.gdbinit: gdbinit
+	if [ -f .gdbinit ]; then \
+	  echo "refusing to overwrite .gdbinit with newer version from $<" 1>&2; \
+	else \
+	  cp $< $@; \
+	fi
+
 BUGS INSTALL.OCTAVE:
 	$(MAKE) -C doc ../$@
 .PHONY: BUGS INSTALL.OCTAVE