diff Makefile.am @ 25801:95eb72d50fb0

build: ensure ChangeLog is built from hg log without --graph * Makefile.am (changelog-from-hg-log): Use 'hg log --no-graph'.
author Mike Miller <mtmiller@octave.org>
date Wed, 15 Aug 2018 13:21:37 -0700
parents 178f6d18c9a8
children 440eb4707570
line wrap: on
line diff
--- a/Makefile.am	Wed Aug 15 13:03:29 2018 -0700
+++ b/Makefile.am	Wed Aug 15 13:21:37 2018 -0700
@@ -362,7 +362,7 @@
   rm -f $@-t && \
   if [ -d $(srcdir)/.hg ]; then \
     ( cd $(srcdir); \
-      hg log --style=build-aux/changelog.tmpl --prune=b0e60ad4ae26 --only-branch=`hg branch`; \
+      hg log --no-graph --style=build-aux/changelog.tmpl --prune=b0e60ad4ae26 --only-branch=`hg branch`; \
       echo ""; \
       echo "See the files in the directory etc/OLD-ChangeLogs for changes before 2011-04-19"; \
     ) > $@-t && \