diff configure.ac @ 26536:b3157525cebf stable

jit: configure: Check llvm::IRBuilder API * m4/acinclude.m4: New macro to check if llvm::IRBuilder has two template arguments (or not, in which case it has three). * configure.ac: Call the new macro. * libinterp/parse-tree/jit-util.h: Adapt IRBuilderD typedef.
author Julien Bect <jbect@users.sourceforge.net>
date Sat, 29 Dec 2018 22:25:25 +0100
parents 00f796120a6d
children 7a77eb39c7f0
line wrap: on
line diff
--- a/configure.ac	Tue Jan 01 07:15:46 2019 +0100
+++ b/configure.ac	Sat Dec 29 22:25:25 2018 +0100
@@ -1419,12 +1419,14 @@
     if test $have_function_h = no; then
       warn_llvm="Missing LLVM file Function.h.  JIT compiler is disabled."
     fi
+
     have_irbuilder_h=no
     AC_CHECK_HEADERS([llvm/Support/IRBuilder.h llvm/IR/IRBuilder.h \
                       llvm/IRBuilder.h], [have_irbuilder_h=yes; break])
     if test $have_irbuilder_h = no; then
       warn_llvm="Missing LLVM file IRBuilder.h.  JIT compiler is disabled."
     fi
+
     have_llvm_data_h=no
     AC_CHECK_HEADERS([llvm/Target/TargetData.h llvm/IR/DataLayout.h \
                       llvm/DataLayout.h], [have_llvm_data_h=yes; break])
@@ -1440,6 +1442,7 @@
     OCTAVE_LLVM_CALLINST_ADDATTRIBUTE_API
     OCTAVE_LLVM_RAW_FD_OSTREAM_API
     OCTAVE_LLVM_LEGACY_PASSMANAGER_API
+    OCTAVE_LLVM_IRBUILDER_API
     AC_LANG_POP(C++)
     CPPFLAGS="$save_CPPFLAGS"
     LDFLAGS="$save_LDFLAGS"