diff configure.ac @ 29688:b36e83cdbf05

ensure idx_vector(int) constructor is defined (bug #60531) * idx-vector.h (idx_vector constructor): Define constructor that accepts int value if not already defined because octave_idx_type is int. Only define specifically for octave_f77_int_type if size is different from both octave_idx_type and int. Eliminate all casts from int to octave_idx_type that were used to avoid overload resolution errors if no int constructor was defined. * configure.ac: Check for sizeof int and also define OCTAVE_SIZEOF_INT. * mk-octave-config-h.sh: Copy OCTAVE_SIZEOF_INT to octave-config.h file.
author John W. Eaton <jwe@octave.org>
date Mon, 17 May 2021 15:26:37 -0400
parents 03d840d96b3a
children 32d345451ccc
line wrap: on
line diff
--- a/configure.ac	Mon May 17 08:01:46 2021 +0200
+++ b/configure.ac	Mon May 17 15:26:37 2021 -0400
@@ -491,6 +491,10 @@
 
 ### Use a 64-bit integer type for array dimensions and indexing, if possible.
 
+AC_CHECK_SIZEOF([int])
+AC_DEFINE_UNQUOTED(OCTAVE_SIZEOF_INT, [$ac_cv_sizeof_int],
+  [Define to the size of int.])
+
 AC_CHECK_SIZEOF([void *])
 if test $ac_cv_sizeof_void_p -ge 8; then
   ENABLE_64=yes