diff configure.ac @ 27013:b37c1656aa42

configure: test all SUNKLU functions after core SUNDIALS features (bug #55937) * configure.ac: Restore SUNDIALS feature test order, reverts cset 5bd4ffb55b1b. * acinclude.m4 (OCTAVE_CHECK_SUNDIALS_COMPATIBLE_API): Do not test for the SUNLinSol_KLU or SUNKLU functions and do not depend on KLU libraries for basic SUNDIALS functionality. (OCTAVE_CHECK_SUNDIALS_SUNLINSOL_KLU): Test for the SUNLinSol_KLU and SUNKLU functions.
author Mike Miller <mtmiller@octave.org>
date Tue, 02 Apr 2019 14:49:58 -0700
parents 5bd4ffb55b1b
children 463fc0cfed90
line wrap: on
line diff
--- a/configure.ac	Tue Apr 02 15:02:19 2019 -0700
+++ b/configure.ac	Tue Apr 02 14:49:58 2019 -0700
@@ -2216,12 +2216,6 @@
   dnl skipped if a warning message has already been generated that SUNDIALS is
   dnl disabled.
   warn_sundials_disabled=
-  dnl If using Sundials 3.1, the test for sunlinsol_klu library must be done before
-  dnl checking for SUNKLU because we must link with the sunlinsol_klu library in
-  dnl order to find the SUNKLU function.
-  if test -z "$warn_sundials_disabled"; then
-    OCTAVE_CHECK_SUNDIALS_SUNLINSOL_KLU
-  fi
   if test -z "$warn_sundials_disabled"; then
     OCTAVE_CHECK_SUNDIALS_COMPATIBLE_API
   fi
@@ -2231,6 +2225,11 @@
   if test -z "$warn_sundials_disabled"; then
     OCTAVE_CHECK_SUNDIALS_SUNLINSOL_DENSE
   fi
+  dnl The following tests determine whether certain optional features are
+  dnl present in the SUNDIALS libraries, but will not disable using SUNDIALS.
+  if test -z "$warn_sundials_disabled"; then
+    OCTAVE_CHECK_SUNDIALS_SUNLINSOL_KLU
+  fi
 fi
 LIBS="$save_LIBS"