diff configure.ac @ 24945:ba9d37893822 stable

build: Don't built special Qt Help files when --without-qt used (bug #53394) * configure.ac: Create new AM_CONDITIONAL named AMCOND_BUILD_QT_DOCS which is valid only when the Qt GUI is being build and documentation is being built. * doc/interpreter/module.mk: Use "if AMCOND_BUILD_QT_DOCS"/"endif" to surround the code used to generate special Qt Help files.
author Rik <rik@octave.org>
date Wed, 21 Mar 2018 12:04:19 -0700
parents c27398f0601c
children 7116fc02ef3a 3c817af70eed
line wrap: on
line diff
--- a/configure.ac	Wed Mar 21 10:27:32 2018 -0700
+++ b/configure.ac	Wed Mar 21 12:04:19 2018 -0700
@@ -2907,6 +2907,9 @@
 fi
 AM_CONDITIONAL([AMCOND_BUILD_DOCS], [test $ENABLE_DOCS = yes])
 
+AM_CONDITIONAL([AMCOND_BUILD_QT_DOCS],
+               [test $ENABLE_DOCS = yes && test $build_qt_gui = yes])
+
 ### Determine whether Mercurial ID should be embedded in library binaries.
 
 ENABLE_HG_ID=yes