diff Makefile.am @ 20308:bacaec9b5535

eliminate recursive make invocation in test directory tree * test/module.mk: New file created from test/Makefile.am, test/bug-35448/module.mk, test/bug-36025/module.mk, test/bug-38236/module.mk, test/bug-38691/module.mk, test/bug-44940/module.mk, test/class-concat/module.mk, test/classdef/module.mk, test/classes/module.mk, test/ctor-vs-method/module.mk, test/fcn-handle-derived-resolution/module.mk, and test/nest/module.mk. * test/Makefile.am, test/bug-35448/module.mk, test/bug-36025/module.mk, test/bug-38236/module.mk, test/bug-38691/module.mk, test/bug-44940/module.mk, test/class-concat/module.mk, test/classdef/module.mk, test/classes/module.mk, test/ctor-vs-method/module.mk, test/fcn-handle-derived-resolution/module.mk, test/nest/module.mk: Delete. * configure.ac (AC_OUTPUT): Don't generate test/Makefile. * Makefile.am: Include test/module.mk. * build-aux/common.mk, test/build-bc-overload-tests.sh: Adapt to changes in Makefile structure.
author John W. Eaton <jwe@octave.org>
date Tue, 07 Jul 2015 10:40:38 -0400
parents c3c1fb44f9b5
children 2d84d27dc9f0
line wrap: on
line diff
--- a/Makefile.am	Fri Jul 03 19:33:19 2015 -0400
+++ b/Makefile.am	Tue Jul 07 10:40:38 2015 -0400
@@ -58,6 +58,7 @@
 MAINTAINERCLEANFILES =
 info_TEXINFOS =
 BUILT_SOURCES =
+TEST_FILES =
 
 IMAGES_SRC =
 IMAGES_EPS =
@@ -70,6 +71,7 @@
 include etc/module.mk
 include examples/module.mk
 include m4/module.mk
+include test/module.mk
 
 # Subdirectories in which to run make recursively.  Other
 # directories are handled directly from this Makefile (see also the
@@ -79,7 +81,7 @@
 if AMCOND_BUILD_GUI
 SUBDIRS += libgui
 endif
-SUBDIRS += src scripts test
+SUBDIRS += src scripts
 
 dist-hook: doc-interpreter-dist-hook docs-dist-hook icons-dist-hook
 
@@ -134,14 +136,6 @@
 	@echo "   make install    - to install (PREFIX=$(prefix))"
 	@echo ""
 
-check: all
-	$(MAKE) -C test check
-
-if AMCOND_HAVE_LLVM
-check-jit: all
-	$(MAKE) -C test check-jit
-endif
-
 run-octave: run-octave.in Makefile
 	$(AM_V_GEN)$(do_subst_script_vals) && \
 	chmod a+rx "$@"