diff Makefile.am @ 20293:d6879b59f46f

eliminate recursive make invocation in examples directory tree * examples/module.mk: New file. * Makefile.am: Include examples/module.mk. (SUBDIRS): Remove examples from the list. * configure.ac (AC_OUTPUT): Don't generate examples/Makefile, examples/code/Makefile, or examples/data/Makefile. * examples/Makefile.am, examples/code/@FIRfilter/module.mk, examples/code/@polynomial/module.mk, examples/code/Makefile.am, examples/data/Makefile.am: Delete.
author John W. Eaton <jwe@octave.org>
date Thu, 02 Jul 2015 17:11:29 -0400
parents 07b970d6cdfe
children 47d704435aa4
line wrap: on
line diff
--- a/Makefile.am	Thu Jul 02 14:23:18 2015 -0400
+++ b/Makefile.am	Thu Jul 02 17:11:29 2015 -0400
@@ -24,6 +24,9 @@
 ## to a confusing error message stream
 .NOTPARALLEL:
 
+octdata_DATA =
+octetc_DATA =
+
 ACLOCAL_AMFLAGS = -I m4
 
 BUILT_DISTFILES = AUTHORS BUGS ChangeLog INSTALL.OCTAVE
@@ -65,6 +68,7 @@
   etc/gdbinit \
   run-octave.in
 
+include examples/module.mk
 include m4/module.mk
 
 # Subdirectories in which to run `make all'.  Including "." before
@@ -81,7 +85,7 @@
 if AMCOND_BUILD_GUI
 SUBDIRS += libgui
 endif
-SUBDIRS += src scripts . @DOCDIR@ examples etc/icons test .
+SUBDIRS += src scripts . @DOCDIR@ etc/icons test .
 
 if ! AMCOND_BUILD_DOCS
 dist-hook:
@@ -171,7 +175,7 @@
 	$(AM_V_GEN)$(changelog-from-hg-log)
 .PHONY: ChangeLog
 
-octetc_DATA = \
+octetc_DATA += \
   CITATION \
   NEWS