diff configure.ac @ 25145:dfc6ccc2a3e8

set dev branch version to 5.0.0 New release version scheme follows that of GCC. Briefly: * Any version X.0.0 means "this is an experimental development version". * Any version X.Y.1 means, "this is a pre-release version meant for bug fixing and testing". * Any version X.Y.0 with Y != 0 means "this is a released version". More info here: http://lists.gnu.org/archive/html/octave-maintainers/2018-03/msg00214.html * configure.ac (AC_INIT): Set version to 5.0.0. (OCTAVE_MAJOR_VERSION): Now 5. (OCTAVE_MAJOR_VERSION, OCTAVE_PATCH_VERSION): Now 0. (OCTAVE_RELEASE_DATE): Set to today; may update after 4.4.0 is released. * chop.m, desktop.m, java2mat.m, tmpnam.m, toascii.m, bitmax.m: Removal version is now 6, not 4.8. * deprecate-props.tst: Update removal version numbers.
author John W. Eaton <jwe@octave.org>
date Sat, 07 Apr 2018 10:37:13 -0400
parents c7de02b5b227
children 325145377713
line wrap: on
line diff
--- a/configure.ac	Fri Apr 06 14:34:24 2018 -0700
+++ b/configure.ac	Sat Apr 07 10:37:13 2018 -0400
@@ -20,7 +20,7 @@
 
 ### Initialize Autoconf
 AC_PREREQ([2.65])
-AC_INIT([GNU Octave], [4.5.0+], [https://octave.org/bugs.html], [octave],
+AC_INIT([GNU Octave], [5.0.0], [https://octave.org/bugs.html], [octave],
         [https://www.gnu.org/software/octave/])
 
 ### Declare version numbers
@@ -28,16 +28,16 @@
 dnl Note that the version number is duplicated here and in AC_INIT because
 dnl AC_INIT requires it to be static, not computed from shell variables.
 
-OCTAVE_MAJOR_VERSION=4
-OCTAVE_MINOR_VERSION=5
-OCTAVE_PATCH_VERSION=0+
+OCTAVE_MAJOR_VERSION=5
+OCTAVE_MINOR_VERSION=0
+OCTAVE_PATCH_VERSION=0
 
 dnl PACKAGE_VERSION is set by the AC_INIT VERSION argument.
 OCTAVE_VERSION="$PACKAGE_VERSION"
 
 OCTAVE_COPYRIGHT="Copyright (C) 2018 John W. Eaton and others."
 
-OCTAVE_RELEASE_DATE="2016-11-13"
+OCTAVE_RELEASE_DATE="2018-04-07"
 
 ## The "API version" is used as a way of checking that interfaces in the
 ## liboctave and libinterp libraries haven't changed in a backwardly