diff Makefile.am @ 22020:e154d23b2fd1

maint: reduce multiple mentions of the HG-ID file name and contents * build-aux/mk-hg-id.sh: Use ${hg_id} variable everywhere HG-ID is mentioned. * Makefile.am (all-local): Use $(HG_ID_VAR) instead of reading HG-ID again. * libgui/src/module.mk (libgui/src/liboctgui-build-info.cc): Likewise. * libinterp/module.mk (libinterp/liboctinterp-build-info.cc): Likewise. * liboctave/module.mk (liboctave/liboctave-build-info.cc): Likewise. * src/module.mk (src/octave-build-info.cc): Likewise.
author Mike Miller <mtmiller@octave.org>
date Fri, 01 Jul 2016 08:14:50 -0700
parents a49ed7b7b66f
children 659731a4563f
line wrap: on
line diff
--- a/Makefile.am	Fri Jul 01 07:48:09 2016 -0400
+++ b/Makefile.am	Fri Jul 01 08:14:50 2016 -0700
@@ -321,7 +321,7 @@
 	@echo "   make check      - to run the tests"
 	@echo "   make install    - to install (PREFIX=$(prefix))"
 	@echo ""
-	@echo "   HG ID for this build is \"`cat HG-ID`\""
+	@echo "   HG ID for this build is \"$(HG_ID_VAR)\""
 	@echo ""
 
 run-octave: run-octave.in build-aux/subst-script-vals.sh
@@ -383,7 +383,8 @@
 .PHONY: ChangeLog
 
 ## The mk-hg-id.sh script will be executed each time Make runs.  It will
-## update the HG-ID file in the build tree if it is out of date.
+## update the HG-ID file in the build tree if it is out of date.  As a side
+## effect, HG_ID_VAR is assigned the contents of the file.
 
 if AMCOND_ENABLE_HG_ID
 HG_ID_VAR := \