diff configure.ac @ 31751:e863066429f1

assume QOffscreenSurface is available QOffscreenSurface was introduced in Qt 5.1. * acinclude.m4 (OCTAVE_CHECK_QT_OPENGL_OFFSCREEN_OK): Delete. (OCTAVE_CHECK_QT_VERSION): Delete use. * configure.ac, geometryimages.m, interpimages.m, module.mk, plotimages.m, sparseimages.m, splineimages.m, GLCanvas.cc, GLCanvas.h, getframe.m, __check_rendering_capability__.m, copyobj.m, hgsave.m, jupyter-notebook.tst, publish.tst: Eliminate checks for Qt OffscreenSurface feature. Assume it is always available.
author John W. Eaton <jwe@octave.org>
date Tue, 17 Jan 2023 13:11:02 -0500
parents 85723a361b2b
children 345a3f5890e7
line wrap: on
line diff
--- a/configure.ac	Tue Jan 17 10:27:03 2023 -0500
+++ b/configure.ac	Tue Jan 17 13:11:02 2023 -0500
@@ -2662,7 +2662,7 @@
    fi], [])
 
 if test $ENABLE_DOCS = yes; then
-  if test $opengl_graphics = no || test "$have_qt_opengl_offscreen" = no; then
+  if test $opengl_graphics = no; then
     if test -n "$warn_gnuplot"; then
       ENABLE_DOCS=no
       warn_docs_graphics="building documentation disabled because no suitable graphics toolkit is available; make dist will fail."