diff Makefile.am @ 21382:eb7287db3da9

create .oct and other files in build tree (bug #46260) * Makefile.am (ALL_LOCAL_TARGETS): Add $(OCTAVE_INTERPRETER_FILES) to the list. (all-local): Simplify by adding all dependencies to ALL_LOCAL_TARGETS. * libinterp/module.mk: (ALL_LOCAL_TARGETS): Delete.
author John W. Eaton <jwe@octave.org>
date Tue, 01 Mar 2016 03:25:14 -0500
parents 1309edb344e1
children ad1dbbd23f1d
line wrap: on
line diff
--- a/Makefile.am	Tue Mar 01 02:27:13 2016 -0500
+++ b/Makefile.am	Tue Mar 01 03:25:14 2016 -0500
@@ -175,7 +175,14 @@
 octinclude_HEADERS += oct-conf-post.h
 nodist_octinclude_HEADERS += config.h octave-config.h
 
-all-local: $(ALL_LOCAL_TARGETS) $(noinst_SCRIPTS) $(DIST_INFO_FILES) .gdbinit $(DOC_TARGETS)
+ALL_LOCAL_TARGETS += \
+  $(OCTAVE_INTERPRETER_TARGETS) \
+  $(noinst_SCRIPTS) \
+  $(DIST_INFO_FILES) \
+  .gdbinit \
+  $(DOC_TARGETS)
+
+all-local: $(ALL_LOCAL_TARGETS)
 	@echo ""
 	@echo "Octave successfully built.  Now choose from the following:"
 	@echo ""