diff configure.ac @ 21187:f569ba0ee237

eliminate FCN_PTR_CAST macro and associated configure test * acinclude.m4 (CTAVE_CXX_BROKEN_REINTERPRET_CAST): Delete macro definition. * configure.ac: Don't use it. * oct-conf-post.in.h (FCN_PTR_CAST): Delete macro definition. * dynamic-ld.cc, mex.cc: Use reinterpret_cast instead of FCN_PTR_CAST macro.
author John W. Eaton <jwe@octave.org>
date Thu, 04 Feb 2016 00:30:42 -0500
parents e7fda94aec6b
children 2cf8bc5c7017
line wrap: on
line diff
--- a/configure.ac	Wed Feb 03 23:44:49 2016 -0500
+++ b/configure.ac	Thu Feb 04 00:30:42 2016 -0500
@@ -2223,9 +2223,6 @@
 
 ### Check compiler characteristics.
 
-## Does reinterpret_cast fail for function pointers?
-OCTAVE_CXX_BROKEN_REINTERPRET_CAST
-
 ## Check if C++ compiler can auto allocate variable sized arrays.
 OCTAVE_CXX_DYNAMIC_AUTO_ARRAYS