diff Makefile.am @ 24844:fc21ac9cd998

only skip .gdbinit install if files differ (bug #53241) * Makefile.am (gdb-install-rule): Rename from gdb_install_rule. Change all uses. Don't skip installation if files are the same. (.gdbinit): Use $(AM_V_GEN) for more consistent output. * test/module.mk: Don't install .gdbinit file in test subdirectory of build tree.
author John W. Eaton <jwe@octave.org>
date Tue, 06 Mar 2018 13:01:12 -0500
parents 194eb4bd202b
children 7c7b60dd4d4c
line wrap: on
line diff
--- a/Makefile.am	Sun Mar 04 03:52:58 2018 -0600
+++ b/Makefile.am	Tue Mar 06 13:01:12 2018 -0500
@@ -344,7 +344,7 @@
 .PHONY: nonexistent-file
 
 .gdbinit: etc/gdbinit
-	@$(gdbinit_install_rule)
+	$(AM_V_GEN)$(gdbinit-install-rule)
 
 define changelog-from-hg-log
   rm -f $@-t && \
@@ -481,11 +481,10 @@
   mv $@-t $@
 endef
 
-define gdbinit_install_rule
-  if [ -f $@ ]; then \
+define gdbinit-install-rule
+  if [ -f $@ ] && ! cmp -s $< $@; then \
     echo "refusing to overwrite $@ with newer version from $<" 1>&2; \
   else \
-    echo "Installing $@ from version at $<" ; \
     cp $< $@; \
   fi
 endef