diff configure.ac @ 29733:fc282fdd1a42 stable

bump version for 6.2.90 release candidate * configure.ac (AC_INIT): Set version to 6.2.90. (OCTAVE_PATCH_VERSION): Set to 90. (OCTAVE_RELEASE_DATE): Set to 2021-06-05. (OCTAVE_API_VERSION): Set to api-v56. * liboctave/module.mk, libgui/module.mk, libinterp/module.mk: Bump version numbers for library revision.
author John W. Eaton <jwe@octave.org>
date Sat, 05 Jun 2021 20:35:58 -0400
parents 99e3912441ec
children 9d70a797d54a
line wrap: on
line diff
--- a/configure.ac	Sat Jun 05 11:04:45 2021 +0200
+++ b/configure.ac	Sat Jun 05 20:35:58 2021 -0400
@@ -27,7 +27,7 @@
 
 ### Initialize Autoconf
 AC_PREREQ([2.65])
-AC_INIT([GNU Octave], [6.2.1], [https://octave.org/bugs.html], [octave],
+AC_INIT([GNU Octave], [6.2.90], [https://octave.org/bugs.html], [octave],
         [https://www.gnu.org/software/octave/])
 
 ### Declare version numbers
@@ -41,14 +41,14 @@
 
 OCTAVE_MAJOR_VERSION=6
 OCTAVE_MINOR_VERSION=2
-OCTAVE_PATCH_VERSION=1
+OCTAVE_PATCH_VERSION=90
 
 dnl PACKAGE_VERSION is set by the AC_INIT VERSION argument.
 OCTAVE_VERSION="$PACKAGE_VERSION"
 
 OCTAVE_COPYRIGHT="Copyright (C) 2021 The Octave Project Developers."
 
-OCTAVE_RELEASE_DATE="2021-02-19"
+OCTAVE_RELEASE_DATE="2021-06-05"
 
 ## The "API version" is used as a way of checking that interfaces in the
 ## liboctave and libinterp libraries haven't changed in a backwardly
@@ -63,7 +63,7 @@
 dnl FIXME: Since we also set libtool versions for liboctave and libinterp,
 dnl perhaps we should be computing the "api version" from those versions numbers
 dnl in some way instead of setting it independently here.
-OCTAVE_API_VERSION="api-v55"
+OCTAVE_API_VERSION="api-v56"
 
 AC_SUBST(OCTAVE_MAJOR_VERSION)
 AC_SUBST(OCTAVE_MINOR_VERSION)