diff Makefile.am @ 30580:fdc30b576333

eliminate code duplication in oct-conf-post.in.h and octave-config.h * oct-conf-post-private.in.h, oct-conf-post-public.in.h: New files, split form oct-conf-post.in.h. * Makefile.am (libgnu/libgnu.la): Depend on oct-conf-post-public.h and oct-conf-post-private.h instead of oct-conf-post.h. (BUILT_SOURCES): Update. (nodist_octinclude_HEADERS): Add oct-conf-post-public.h to the list. * build-aux/module.mk (GEN_CONFIG_INC): Replace oct-conf-post.h with oct-conf-post-private.h and oct-conf-post-public.h. * configure.ac: Replace code using oct-conf-post.h with equivalent actions for oct-conf-post-private.h and oct-conf-post-public.h. * mk-octave-config-h.sh: Instead of generating code that is also duplicated in oct-conf-post.h, include the file oct-conf-post-public.h that is also included in Octave's config.h file.
author John W. Eaton <jwe@octave.org>
date Fri, 31 Dec 2021 09:28:05 -0500
parents 83f9f8bda883
children 4392386b5ecb
line wrap: on
line diff
--- a/Makefile.am	Fri Sep 24 16:01:39 2021 -0500
+++ b/Makefile.am	Fri Dec 31 09:28:05 2021 -0500
@@ -233,7 +233,7 @@
 # See bug #45578.
 BUILT_SOURCES += libgnu/libgnu.la
 
-libgnu/libgnu.la: oct-conf-post.h
+libgnu/libgnu.la: oct-conf-post-private.h oct-conf-post-public.h
 	cd libgnu && $(MAKE) $(AM_MAKEFLAGS) all
 
 include liboctave/module.mk
@@ -299,7 +299,8 @@
 endif
 
 BUILT_SOURCES += \
-  oct-conf-post.h \
+  oct-conf-post-private.h \
+  oct-conf-post-public.h \
   octave-config.h \
   run-octave \
   $(DIRSTAMP_FILES)
@@ -331,6 +332,7 @@
 CONFIG_FILES = @ac_config_headers@ @ac_config_files@
 
 nodist_octinclude_HEADERS += \
+  oct-conf-post-public.h \
   octave-config.h
 
 OCTAVE_INTERPRETER_TARGETS += \