diff Makefile.am @ 115:00d19f71c9ca

Initial implementation of py oct-file * py.cc: Initial implementation of py oct function. * ax_octave.m4: Find and export path to mkoctfile. * Makefile.am (.cc.oct): Custom rule to build py.oct. (all-am): Depend on py.oct. * .hgignore: Include py.oct in the ignore list.
author Mike Miller <mtmiller@octave.org>
date Sun, 20 Sep 2015 15:12:47 +0200
parents 6450086b1934
children 386772f4e12d
line wrap: on
line diff
--- a/Makefile.am	Sun Sep 20 02:57:31 2015 +0200
+++ b/Makefile.am	Sun Sep 20 15:12:47 2015 +0200
@@ -14,3 +14,10 @@
 _pytave_la_SOURCES = octave_to_python.cc pytave.cc python_to_octave.cc \
 arrayobjectdefs.h octave_to_python.h pytavedefs.h exceptions.h   \
 exceptions.cc python_to_octave.h config.h
+
+all-am: py.oct
+
+.cc.oct:
+	$(MKOCTFILE) $(DEFS) $(_pytave_la_CPPFLAGS) $< exceptions.cc octave_to_python.cc python_to_octave.cc -l$(BOOST_PYTHON_LIB) $(PYTHON_LIBS) -o $@
+
+SUFFIXES = .oct