diff Makefile.am @ 306:2ecae5c6eeb6

Refactor code, have common functions in pytave_utils * pytave_utils.{h,cc}: Have the 2 functions to get builtins module and an object from python as utils. * Makefile.am: Add pytave_utils{h,cc} to the build process. * pycall.cc: Use pytave_utils to get FUNC from python and remove unused code. * python_to_octave.cc: Use pytave_utils to get the builtins module
author Abhinav Tripathi <genuinelucifer@gmail.com>
date Tue, 09 Aug 2016 11:27:38 -0700
parents 0c6f7ae8a95b
children 77af526c687a
line wrap: on
line diff
--- a/Makefile.am	Wed Aug 03 16:23:09 2016 -0700
+++ b/Makefile.am	Tue Aug 09 11:27:38 2016 -0700
@@ -27,7 +27,8 @@
 COMMON_SOURCE_FILES = \
   exceptions.cc \
   octave_to_python.cc \
-  python_to_octave.cc
+  python_to_octave.cc \
+  pytave_utils.cc
 
 DOC_FILES = \
   INSTALL.md \
@@ -45,7 +46,8 @@
   config.h \
   exceptions.h \
   octave_to_python.h \
-  python_to_octave.h
+  python_to_octave.h \
+  pytave_utils.h
 
 PY_FILES = \
   package/__init__.py \