diff Makefile.am @ 411:3613ffbd52b2

Overhaul implicit conversion of arguments and return values * oct-py-types.cc, oct-py-types.h (pytave::py_implicitly_convert_argument, pytave::py_implicitly_convert_return_value): New functions. * __py_struct_from_dict__.cc, oct-py-eval.cc, pycall.cc, pyeval.cc, pyexec.cc: Use them instead of legacy conversion functions. Add necessary #includes, remove #includes of legacy header files. * @pyobject/subsasgn.m, @pyobject/subsref.m: Change %!tests that depend on NumPy implicit conversion into %!xtests. * octave_to_python.cc, octave_to_python.h, python_to_octave.cc, python_to_octave.h: Delete, no longer used. * Makefile.am (COMMON_SOURCE_FILES, PYTAVE_HEADER_FILES): Remove the files.
author Mike Miller <mtmiller@octave.org>
date Wed, 03 May 2017 16:30:45 -0700
parents 478d83448b0b
children db29823a8919
line wrap: on
line diff
--- a/Makefile.am	Tue May 02 17:40:01 2017 -0700
+++ b/Makefile.am	Wed May 03 16:30:45 2017 -0700
@@ -29,12 +29,10 @@
 
 COMMON_SOURCE_FILES = \
   exceptions.cc \
-  octave_to_python.cc \
   oct-py-eval.cc \
   oct-py-init.cc \
   oct-py-types.cc \
-  oct-py-util.cc \
-  python_to_octave.cc
+  oct-py-util.cc
 
 DOC_FILES = \
   INSTALL.md \
@@ -72,9 +70,7 @@
   oct-py-init.h \
   oct-py-object.h \
   oct-py-types.h \
-  oct-py-util.h \
-  octave_to_python.h \
-  python_to_octave.h
+  oct-py-util.h
 
 TST_FILES = $(addsuffix -tst,$(OCT_SOURCE_FILES))