diff Makefile.am @ 405:478d83448b0b

Refactor Python initialization into a common function * oct-py-init.cc, oct-py-init.h: New files defining a pytave::py_init function. * __py_struct_from_dict__.cc, pycall.cc, pyeval.cc, pyexec.cc: Use it instead of initializing Python differently in each entry point. * Makefile.am (COMMON_SOURCE_FILES): Include oct-py-init.cc in the list. (PYTAVE_HEADER_FILES): Include oct-py-init.h in the list.
author Mike Miller <mtmiller@octave.org>
date Sat, 29 Apr 2017 15:43:42 -0700
parents 3905052ebe1d
children 3613ffbd52b2
line wrap: on
line diff
--- a/Makefile.am	Fri Apr 28 16:21:39 2017 -0700
+++ b/Makefile.am	Sat Apr 29 15:43:42 2017 -0700
@@ -31,6 +31,7 @@
   exceptions.cc \
   octave_to_python.cc \
   oct-py-eval.cc \
+  oct-py-init.cc \
   oct-py-types.cc \
   oct-py-util.cc \
   python_to_octave.cc
@@ -68,6 +69,7 @@
   config.h \
   exceptions.h \
   oct-py-eval.h \
+  oct-py-init.h \
   oct-py-object.h \
   oct-py-types.h \
   oct-py-util.h \