diff Makefile.am @ 423:6b9de18b4bdd

Eliminate remaining custom exception handling in favor of Octave errors * oct-py-error.cc, oct-py-error.h (pytave::error_python_exception): New function to generate an Octave error from an active Python error condition, based on pytave::fetch_exception_message. * oct-py-eval.cc (pytave::py_call_function, pytave::py_run_string_safe): Use it. * oct-py-types.cc (pytave::make_py_dict): Likewise. * oct-py-util.cc (pytave::py_objstore): Likewise. * pycall.cc (Fpycall): Remove exception handling logic. * pyeval.cc (Fpyeval): Likewise. * pyexec.cc (Fpyexec): Likewise. * exceptions.cc, exceptions.h: Delete. * Makefile.am (COMMON_SOURCE_FILES, PYTAVE_HEADER_FILES): Remove them.
author Mike Miller <mtmiller@octave.org>
date Thu, 04 May 2017 21:15:07 -0700
parents 8247f298fd16
children 14b134ffdc24
line wrap: on
line diff
--- a/Makefile.am	Thu May 04 17:13:38 2017 -0700
+++ b/Makefile.am	Thu May 04 21:15:07 2017 -0700
@@ -29,7 +29,6 @@
 export INCFLAGS
 
 COMMON_SOURCE_FILES = \
-  exceptions.cc \
   oct-py-error.cc \
   oct-py-eval.cc \
   oct-py-init.cc \
@@ -66,7 +65,6 @@
 
 PYTAVE_HEADER_FILES = \
   config.h \
-  exceptions.h \
   oct-py-error.h \
   oct-py-eval.h \
   oct-py-init.h \