diff configure.ac @ 416:aeed116cf9f9

build: drop build-time dependency on Boost * Makefile.am (OCT_LIBS): Remove -l$(BOOST_PYTHON_LIB). * bitbucket-pipelines.yml: Don't install libboost-python-dev. * configure.ac: Remove call to AX_BOOST_PYTHON. * m4/ax_boost_base.m4, m4/ax_boost_python.m4: Delete.
author Mike Miller <mtmiller@octave.org>
date Wed, 03 May 2017 21:50:37 -0700
parents 4f415a887ff8
children 4e427ec1650a
line wrap: on
line diff
--- a/configure.ac	Wed May 03 21:48:07 2017 -0700
+++ b/configure.ac	Wed May 03 21:50:37 2017 -0700
@@ -45,12 +45,6 @@
 # Pick a Python library to use
 AX_PYTHON_DEVEL
 
-# Look for boost::python
-AX_BOOST_PYTHON
-if test -z "$BOOST_PYTHON_LIB"; then
-  AC_MSG_FAILURE([unable to find Boost::Python development files])
-fi
-
 AM_INIT_AUTOMAKE([foreign -Wno-portability])
 LT_INIT
 
@@ -79,6 +73,5 @@
   Python ............. $PYTHON_CPPFLAGS
     library .......... $PYTHON_LIBS
     executable ....... $PYTHON
-  Boost::Python ...... $BOOST_PYTHON_LIB
 
 ========================================================================])