diff Makefile.am @ 165:c0964adb41fc

build: Output a hint about what to do next after a successful build * Makefile.am (all-local): Add a successful build message similar to Octave.
author Mike Miller <mtmiller@octave.org>
date Wed, 06 Apr 2016 14:26:16 -0700
parents bc4f2e6f7b69
children f687155dcb7c
line wrap: on
line diff
--- a/Makefile.am	Wed Apr 06 10:23:28 2016 -0700
+++ b/Makefile.am	Wed Apr 06 14:26:16 2016 -0700
@@ -82,6 +82,18 @@
 	$(AM_V_MKOCTFILE)$(OCT_LINK) $< $(OCT_LIBS)
 
 all-local: $(OCT_FILES)
+	@echo ""
+	@echo "Pytave successfully built.  Now choose from the following:"
+	@echo ""
+	@echo "  * run the test suite"
+	@echo "    make check"
+	@echo ""
+	@echo "  * run an Octave session with py* functions"
+	@echo "    octave --path=\"\$$(pwd)\""
+	@echo ""
+	@echo "  * run a Python session with pytave package"
+	@echo "    PYTHONPATH=\"\$$(pwd)/.libs:\$$(pwd)/package\" python"
+	@echo ""
 
 check-local:
 	PYTHONPATH="$$(pwd)/package:$$(pwd)/.libs" $(PYTHON) test/exceptions.py