diff Makefile.am @ 385:132fec49e438

build: support user selection of Octave version or prefix or both * m4/ax_octave.m4: Add OCTAVE and OCTAVE_VERSION input variables. Test for Octave programs with optional suffix derived from OCTAVE_VERSION. * Makefile.am (check-local): Use configured $(OCTAVE) interpreter. Add options to avoid unnecessary initialization.
author Mike Miller <mtmiller@octave.org>
date Sun, 02 Apr 2017 16:24:02 -0700
parents d18843ff4dfd
children 1af368713379
line wrap: on
line diff
--- a/Makefile.am	Sun Apr 02 15:29:34 2017 -0700
+++ b/Makefile.am	Sun Apr 02 16:24:02 2017 -0700
@@ -153,4 +153,6 @@
 	@echo ""
 
 check-local: $(M_FILES) $(TST_FILES)
-	octave-cli --path="$(abs_builddir)" --path="$(abs_srcdir)" __py_tests__.m $(M_FILES) $(TST_FILES)
+	$(OCTAVE) --no-gui-libs --no-history --no-window-system --norc \
+		  --path="$(abs_builddir)" --path="$(abs_srcdir)" \
+		  __py_tests__.m $(M_FILES) $(TST_FILES)