diff Makefile.am @ 311:77af526c687a

build: ensure project config.h is included properly * Makefile.am (INCFLAGS): Set to $(DEFAULT_INCLUDES) and export to the environment. Forces mkoctfile to include project header files before external header files.
author Mike Miller <mtmiller@octave.org>
date Tue, 09 Aug 2016 15:40:52 -0700
parents 2ecae5c6eeb6
children c2aa34730dc9
line wrap: on
line diff
--- a/Makefile.am	Tue Aug 09 15:38:27 2016 -0700
+++ b/Makefile.am	Tue Aug 09 15:40:52 2016 -0700
@@ -24,6 +24,9 @@
 
 AM_CPPFLAGS = $(OCTAVE_CPPFLAGS) $(PYTHON_CPPFLAGS) -I$(NUMPY_INCLUDEDIR)
 
+INCFLAGS = $(DEFAULT_INCLUDES)
+export INCFLAGS
+
 COMMON_SOURCE_FILES = \
   exceptions.cc \
   octave_to_python.cc \