diff Makefile.am @ 335:9b862844e6b7

Enable Python print function in evaluated expressions (fixes issue #48) * oct-py-eval.cc, oct-py-eval.h: New files. * Makefile.am (COMMON_SOURCE_FILES, PYTAVE_HEADER_FILES): Add oct-py-eval.cc and oct-py-eval.h to the build system. * pyeval.cc (Fpyeval): Use pytave::py_eval_string. * pyexec.cc (Fpyexec): Use pytave::py_exec_string.
author Mike Miller <mtmiller@octave.org>
date Mon, 15 Aug 2016 15:16:24 -0700
parents cee203ea6245
children baff3b90dcb1
line wrap: on
line diff
--- a/Makefile.am	Mon Aug 15 14:19:15 2016 -0700
+++ b/Makefile.am	Mon Aug 15 15:16:24 2016 -0700
@@ -30,6 +30,7 @@
 COMMON_SOURCE_FILES = \
   exceptions.cc \
   octave_to_python.cc \
+  oct-py-eval.cc \
   oct-py-types.cc \
   oct-py-util.cc \
   python_to_octave.cc
@@ -49,6 +50,7 @@
   arrayobjectdefs.h \
   config.h \
   exceptions.h \
+  oct-py-eval.h \
   oct-py-types.h \
   oct-py-util.h \
   octave_to_python.h \