diff configure.ac @ 4195:3262d92eff57

configure.in: Create PKG_SRC directory if it doesn't exist.
author John W. Eaton <jwe@octave.org>
date Mon, 29 Aug 2016 14:21:19 -0400
parents 3dc897731d3b
children 667aa26d9dd4
line wrap: on
line diff
--- a/configure.ac	Mon Aug 29 13:26:30 2016 -0400
+++ b/configure.ac	Mon Aug 29 14:21:19 2016 -0400
@@ -66,7 +66,7 @@
   *)
     PKG_DIR="$withval"
     ## Ensure directory exists and that we refer to it using an absolute name
-    if test -d "$PKG_DIR"; then
+    if ! test -d "$PKG_DIR"; then
       mkdir -p "$PKG_DIR"
     fi
     PKG_DIR=`(cd "$PKG_DIR"; pwd)`