diff configure.ac @ 4222:44b1a9b2193e

qt5: add initial qt5 to mxe-octave, based on mxe.cc * src/qt5.mk: new file * src/qtbase-1-fixes.patch: new file * src/qtbase.mk: new file * src/qtimageformats-1.patch: new file * src/qtimageformats.mk: new file * src/qtsvg.mk: new file * src/qttools-1.patch: new file * added src/qttools.mk: new file * changed Makefile.in: added ENABLE_QT5 option * configure.ac: added enable-qt5 option * index.html: added new files to packages * installer-files/octave-firsttime.vbs: added setup of qt5 bin, plugin path * installer-files/octave.vbs: added setup of qt5 bin, plugin path * installer-files/octave.bat: added setup of qt5 bin path * src/default-octave.mk: added settig fot qt5 usage * src/qscintilla.mk: added qt5 path
author John D
date Thu, 29 Sep 2016 11:22:51 -0400
parents 667aa26d9dd4
children b6819fef128f
line wrap: on
line diff
--- a/configure.ac	Tue Sep 27 16:00:44 2016 -0400
+++ b/configure.ac	Thu Sep 29 11:22:51 2016 -0400
@@ -231,6 +231,14 @@
   [if test "$enableval" = yes; then ENABLE_DEVEL_TOOLS=yes; fi], [])
 AC_SUBST(ENABLE_DEVEL_TOOLS)
 
+ENABLE_QT5=no
+AC_ARG_ENABLE([qt5],
+  [AS_HELP_STRING([--enable-qt5],
+    [Enable compile of GNU octave using Qt5 (Experimental)])],
+  [if test "$enableval" = yes; then ENABLE_QT5=yes; fi], [])
+AC_SUBST(ENABLE_QT5)
+
+
 ### Default is to cross compile for mingw.
 
 echo $host_alias