diff configure.ac @ 3611:5ab3fc53d7a5

Add enable/disable-stable configure option * Makefile.in: set stable build dependant on configure variable ENABLE_STABLE. * configure.ac: add --enable-stable arg. * src/octave.mk: set devel octave to 3.8.2-rc1
author John Donoghue
date Tue, 10 Jun 2014 11:35:10 -0400
parents e04d9375cd5f
children 154b7f3af5eb
line wrap: on
line diff
--- a/configure.ac	Mon Jun 09 08:00:17 2014 -0400
+++ b/configure.ac	Tue Jun 10 11:35:10 2014 -0400
@@ -139,6 +139,13 @@
   [if test "$enableval" = yes; then ENABLE_OPENBLAS=yes; fi], [])
 AC_SUBST(ENABLE_OPENBLAS)
 
+ENABLE_STABLE=yes
+AC_ARG_ENABLE(stable,
+  [AS_HELP_STRING([--enable-stable],
+    [Enable stable build of octave instead of devel octave])],
+  [if test "$enableval" = no; then ENABLE_STABLE=no; fi], [])
+AC_SUBST(ENABLE_STABLE)
+
 ### Default is to cross compile for mingw.
 
 echo $host_alias