diff configure.ac @ 3721:933b99febcf1

Expand options to support 3 possible sources of octave * configure.ac: modify --enable-stable rule to --enable-octave=source (stable,alpha,default) * Makefile.am: modify OCTAVE_TARGET based on octave build value set in configure. * index.html: added master-octave information. * src/default-octave.mk: new file. * src/default-octave-1-docinstall.patch * dist-files.mk: add default-octave-1-docinstall.patch default-octave.mk * binary-dist-rules.mk: use OCTAVE_TARGET to decide on tarball/installer name
author John Donoghue <john.donoghue@ieee.org>
date Sun, 19 Oct 2014 22:58:20 -0400
parents 023f392ce053
children 5e79ab51035f
line wrap: on
line diff
--- a/configure.ac	Sun Oct 05 11:12:39 2014 -0400
+++ b/configure.ac	Sun Oct 19 22:58:20 2014 -0400
@@ -150,12 +150,29 @@
   [if test "$enableval" = no; then ENABLE_OPENBLAS=no; fi], [])
 AC_SUBST(ENABLE_OPENBLAS)
 
-ENABLE_STABLE=yes
-AC_ARG_ENABLE([stable],
-  [AS_HELP_STRING([--disable-stable],
-    [Disable stable build of octave and use devel octave instead])],
-  [if test "$enableval" = no; then ENABLE_STABLE=no; fi], [])
-AC_SUBST(ENABLE_STABLE)
+ENABLE_OCTAVE=stable
+AC_ARG_ENABLE([octave],
+  [AS_HELP_STRING([--enable-octave=stable],
+    [Enable a specific build of octave (stable, alpha, default)])],
+  [], [])
+
+case $enableval in
+ stable)
+   ENABLE_OCTAVE="stable-"
+   ;;
+ alpha)
+   ENABLE_OCTAVE=""
+   ;;
+ default)
+   ENABLE_OCTAVE="default-"
+   ;;
+ *)
+   ENABLE_OCTAVE="stable-"
+   AC_MSG_WARN([Unknown octave type $enableval - using enable-octave=stable])
+   ;;
+esac
+   
+AC_SUBST(ENABLE_OCTAVE)
 
 ### Default is to cross compile for mingw.