diff configure.ac @ 4854:990b5e6b1970

use AC_PATH_PROG to check for ccache; use result in ccache-links Makefile rule
author John W. Eaton <jwe@octave.org>
date Wed, 10 Oct 2018 14:39:43 -0400
parents 2ee6a02e6f28
children 2bffe6abd696
line wrap: on
line diff
--- a/configure.ac	Wed Oct 10 14:31:19 2018 -0400
+++ b/configure.ac	Wed Oct 10 14:39:43 2018 -0400
@@ -82,7 +82,7 @@
      *) AC_MSG_ERROR([bad value "$enableval" for --with-ccache]) ;;
    esac], [USE_CCACHE=no])
 if test "$USE_CCACHE" = yes; then
-  AC_CHECK_PROG(CCACHE, ccache, ccache)
+  AC_PATH_PROG(CCACHE, ccache)
   if test -z "$CCACHE"; then
     AC_MSG_WARN([ccache program not found; not using ccache for build])
     USE_CCACHE=no