diff configure.ac @ 3068:fb0836e4a677

Add --enable-openblas option to configure * src/octave.mk: Set --with-blas=openblas if openblas was enabled and add openblas as an octave dependancy. * configure.ac: Add experimental --with-openblas opyion. * Makefile.in: Add ENABLE_OPENBAS flag.
author John Donoghue <john.donoghue@ieee.org>
date Thu, 20 Jun 2013 06:29:17 -0400
parents cbdf4575016d
children 21586f2d1fe7
line wrap: on
line diff
--- a/configure.ac	Tue Jun 18 21:04:49 2013 -0400
+++ b/configure.ac	Thu Jun 20 06:29:17 2013 -0400
@@ -101,6 +101,13 @@
   [if test "$enableval" = yes; then USE_PIC_FLAG=yes; fi], [])
 AC_SUBST(USE_PIC_FLAG)
 
+ENABLE_OPENBLAS=false
+AC_ARG_ENABLE([openblas],
+  [AS_HELP_STRING([--enable-openblas],
+    [(EXPERIMENTAL) enable use of openblas in Octave])],
+  [if test "$enableval" = yes; then ENABLE_OPENBLAS=yes; fi], [])
+AC_SUBST(ENABLE_OPENBLAS)
+
 ### Default is to cross compile for mingw.
 
 echo $host_alias